summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-12 03:26:56 -0400
committerMark H Weaver <mhw@netris.org>2018-04-12 04:02:23 -0400
commit8eb66f4a6829c454285c9d395b6c287fe0dcf8a7 (patch)
tree59ef588e6fb7b37bd8e9c9dbb078d6f34c3c5b36 /gnu
parentfed9078906baad8ed94e2075a4a8acf41f34a244 (diff)
downloadguix-8eb66f4a6829c454285c9d395b6c287fe0dcf8a7.tar.gz
gnu: python-waf: Return #t from all phases.
* gnu/packages/python.scm (python-waf)[arguments]: Use invoke instead of
system*, and return #t from all phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index be93d430ff..630396c43f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5403,13 +5403,14 @@ so it might be a tiny bit slower.")
        (modify-phases %standard-phases
          (replace 'build
            (lambda _
-             (zero? (system* "python" "waf-light" "configure" "build"))))
+             (invoke "python" "waf-light" "configure" "build")))
          (replace 'check
            (lambda _
-             (zero? (system* "python" "waf" "--version"))))
+             (invoke "python" "waf" "--version")))
          (replace 'install
            (lambda _
-             (copy-file "waf" %output))))))
+             (copy-file "waf" %output)
+             #t)))))
     (home-page "https://waf.io/")
     (synopsis "Python-based build system")
     (description