summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-18 21:10:33 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-18 21:10:33 +0100
commit905783b7cd042f20d57b1df2c852ec36220d2030 (patch)
tree4a8e833b31853d3841fe25b5d7e5aafeceb00628 /gnu
parentaaa4f5193c8042df1d46637045ae046e2124aeb1 (diff)
downloadguix-905783b7cd042f20d57b1df2c852ec36220d2030.tar.gz
gnu: emacs-flycheck: Improve package style.
* gnu/packages/emacs-xyz.scm (emacs-flycheck)[arguments]: Use
G-expressions.  Remove trailing #T.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8e86d03682..f5281773c2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1654,20 +1654,22 @@ supports type hints, definition-jumping, completion, and more.")
       (native-inputs
        (list emacs-shut-up))
       (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'change-flycheck-version
-             (lambda _
-               (substitute* "flycheck.el"
-                 (("\\(pkg-info-version-info 'flycheck\\)")
-                  (string-append "\"" ,version "\"")))
-               #t)))
-         ;; TODO: many failing tests
-         #:tests? #f
-         #:test-command '("emacs" "-Q" "--batch" "-L" "."
-                          "--load" "test/flycheck-test"
-                          "--load" "test/run.el"
-                          "-f" "flycheck-run-tests-main")))
+       (list
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'change-flycheck-version
+              (lambda _
+                (substitute* "flycheck.el"
+                  (("\\(pkg-info-version-info 'flycheck\\)")
+                   (string-append "\"" #$version "\""))))))
+        ;; TODO: many failing tests
+        #:tests? #f
+        #:test-command
+        #~(list "emacs" "-Q" "--batch"
+                "-L" "."
+                "--load" "test/flycheck-test"
+                "--load" "test/run.el"
+                "-f" "flycheck-run-tests-main")))
       (home-page "https://www.flycheck.org")
       (synopsis "On-the-fly syntax checking")
       (description