summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-04-26 18:16:36 +0530
committerEfraim Flashner <efraim@flashner.co.il>2022-05-09 11:18:09 +0300
commit9258576eea4589a2fa228a8cb9594de8e9ed4526 (patch)
tree43cb9437c806b5fc50ba8ad59092230c78a9fbd2 /gnu
parent713dadf47e2ceeaa86487709df74a6746f3e86e4 (diff)
downloadguix-9258576eea4589a2fa228a8cb9594de8e9ed4526.tar.gz
gnu: fastahack: Use compiler specific to the build target.
* gnu/packages/bioinformatics.scm (fastahack)[arguments]: Set CXX in
#:make-flags. In the build-dynamic phase, use cxx-for-target instead of g++.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c2caa507e4..d913bb9fdf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14502,7 +14502,8 @@ neural networks.")
        (base32 "0rp1blskhzxf7vbh253ibpxbgl9wwgyzf1wbkxndi08d3j4vcss9"))))
     (build-system gnu-build-system)
     (arguments
-     (list #:tests? #f ; Unclear how to run tests: https://github.com/ekg/fastahack/issues/15
+     (list #:make-flags #~(list (string-append "CXX=" #$(cxx-for-target)))
+           #:tests? #f ; Unclear how to run tests: https://github.com/ekg/fastahack/issues/15
            #:phases
            #~(modify-phases %standard-phases
                (delete 'configure) ; There is no configure phase.
@@ -14512,7 +14513,7 @@ neural networks.")
                      (("-c ") "-c -fPIC "))))
                (add-after 'build 'build-dynamic
                  (lambda _
-                   (invoke "g++"
+                   (invoke #$(cxx-for-target)
                            "-shared" "-o" "libfastahack.so"
                            "Fasta.o" "FastaHack.o" "split.o" "disorder.o")))
                (replace 'install