summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-29 17:11:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-02 17:31:39 +0200
commita3c6445be5f18ea7af2e26f9ee1344b06e02593b (patch)
tree691b74dba891afb4f9a242d1327dfbb782d58d7c /gnu
parentc6ab73e8ff357ea35c3d0ebf1b09c6c7be300a94 (diff)
downloadguix-a3c6445be5f18ea7af2e26f9ee1344b06e02593b.tar.gz
gnu: Add r-purrr.
* gnu/packages/statistics.scm (r-purrr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 51294e5b3b..fd5aaf4b75 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3117,6 +3117,31 @@ and tidyr provides no margins or aggregation.")
 It uses and relies on grid graphics and formal (S4) classes and methods.")
     (license license:gpl2+)))
 
+(define-public r-purrr
+  (package
+    (name "r-purrr")
+    (version "0.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "purrr" version))
+       (sha256
+        (base32
+         "0lss8q733nv7s154wargm6vnxq55qygnxakib8xdj4jv0y86sxc3"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bh" ,r-bh)
+       ("r-dplyr" ,r-dplyr)
+       ("r-lazyeval" ,r-lazyeval)
+       ("r-magrittr" ,r-magrittr)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/hadley/purrr")
+    (synopsis "Functional programming tools")
+    (description
+     "This package completes R's functional programming tools with missing
+features present in other programming languages.")
+    (license license:gpl3+)))
+
 (define-public r-plotly
   (package
     (name "r-plotly")