summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-29 22:16:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-29 22:17:37 +0100
commita7d6e1b6a16534a3afdcecf5d45ed3f5ba9bc3c1 (patch)
treec3e20703b7123cf06edcd83aa15c91558437817e /gnu
parentda2877237ecd0e1c837758ee5e07ab450c827537 (diff)
downloadguix-a7d6e1b6a16534a3afdcecf5d45ed3f5ba9bc3c1.tar.gz
gnu: r-ldheatmap: Move to (gnu packages bioconductor).
This is a follow-up to commit 0c8bb20b7cbd39537999fce29979a6acaf64e601.

* gnu/packages/cran.scm (r-ldheatmap): Move this from here...
* gnu/packages/bioconductor.scm (r-ldheatmap): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm28
-rw-r--r--gnu/packages/cran.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 55df9bf7d1..f1af34844f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9618,6 +9618,34 @@ handling of existing population-level data for the purpose of flexibly
 defining LD blocks.")
     (license license:artistic2.0)))
 
+;; This is a CRAN package, but it depends on r-snpstats, which is a
+;; Bioconductor package.
+(define-public r-ldheatmap
+  (package
+    (name "r-ldheatmap")
+    (version "1.0-4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "LDheatmap" version))
+       (sha256
+        (base32
+         "1jp578cf29qcgx95w10lpymlwx2pgjsf0nypwkl9b8g635gkisq7"))))
+    (properties `((upstream-name . "LDheatmap")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-genetics" ,r-genetics)
+       ("r-rcpp" ,r-rcpp)
+       ("r-snpstats" ,r-snpstats)))
+    (home-page "https://stat.sfu.ca/statgen/research/ldheatmap.html")
+    (synopsis "Graphical display of pairwise linkage disequilibria between SNPs")
+    (description
+     "This package provides tools to produce a graphical display, as a heat
+map, of measures of pairwise linkage disequilibria between SNPs.  Users may
+optionally include the physical locations or genetic map distances of each SNP
+on the plot.")
+    (license license:gpl3)))
+
 (define-public r-pathview
   (package
     (name "r-pathview")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c0926d9fb3..0483af3d6b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14718,34 +14718,6 @@ effects.  It is applicable to backcrosses, doubled haploids, recombinant
 inbred lines, F2 intercrosses, and association mapping populations.")
     (license license:gpl2)))
 
-(define-public r-ldheatmap
-  (package
-    (name "r-ldheatmap")
-    (version "1.0-4")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (cran-uri "LDheatmap" version))
-       (sha256
-        (base32
-         "1jp578cf29qcgx95w10lpymlwx2pgjsf0nypwkl9b8g635gkisq7"))))
-    (properties `((upstream-name . "LDheatmap")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-genetics" ,r-genetics)
-       ("r-rcpp" ,r-rcpp)
-       ("r-snpstats" ,(module-ref
-                       (resolve-interface '(gnu packages bioconductor))
-                       'r-snpstats))))
-    (home-page "https://stat.sfu.ca/statgen/research/ldheatmap.html")
-    (synopsis "Graphical display of pairwise linkage disequilibria between SNPs")
-    (description
-     "This package provides tools to produce a graphical display, as a heat
-map, of measures of pairwise linkage disequilibria between SNPs.  Users may
-optionally include the physical locations or genetic map distances of each SNP
-on the plot.")
-    (license license:gpl3)))
-
 (define-public r-hwde
   (package
     (name "r-hwde")