summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:39:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:10 +0200
commitb16a1f98c9d8563c9e3ee7d0add7ed720e2f7074 (patch)
tree9dd46c68d657609f81a859aca5c53c83797034d0 /gnu
parent0050d124fd3df1fcd270fc839931c818a8e1fd7f (diff)
downloadguix-b16a1f98c9d8563c9e3ee7d0add7ed720e2f7074.tar.gz
gnu: Add texlive-physics2.
* gnu/packages/tex.scm (texlive-physics2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 233195037f..081284051c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5426,6 +5426,34 @@ from true constants, e.g. the fine structure constant, have been calculated
 using the accepted values of the fundamental constants.")
     (license license:lppl1.3c)))
 
+(define-public texlive-physics2
+  (package
+    (name "texlive-physics2")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/physics2/" "tex/latex/physics2/")
+             (base32
+              "03xq3cvyv4d01kmk4p14qkvyrfs583jlrjcbn9vy66gk6gcailih")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/physics2")
+    (synopsis "Macros for typesetting math faster and more simply")
+    (description
+     "The @code{physics2} package defines commands for typesetting math
+formulae faster andmore simply.  @code{physics2} is a modularized package,
+each module provides its own function.  You can load modules separately after
+loading @code{physics2}.
+
+Modules of physics provide the following supports:
+@itemize
+@item automatic braces,
+@item Dirac bracket notation,
+@item easy way to typeset diagonal matrices and matrices with similar entries,
+@item double cross and double dot (binary) operators for tensors.
+@end itemize")
+    (license license:lppl1.3c)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")