summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 13:29:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:44 +0200
commitb3ce1caa470d84f64e2eccc1b7ad3a1b27945c3e (patch)
treef0680916a454dfad3a6cfddf22cab7c68b1f3ca8 /gnu
parentdbe85d4ce71b4dcd491d71ea1619ae4e64d6aafc (diff)
downloadguix-b3ce1caa470d84f64e2eccc1b7ad3a1b27945c3e.tar.gz
gnu: Add texlive-margbib.
* gnu/packages/tex.scm (texlive-margbib): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 03908c830e..c54060462c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12696,6 +12696,26 @@ Riichi (aka Japanese) Mahjong but can be used to typeset any style of
 mahjong.")
     (license (list license:expat license:cc-by4.0))))
 
+(define-public texlive-margbib
+  (package
+    (name "texlive-margbib")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/margbib/" "source/latex/margbib/"
+                   "tex/latex/margbib/")
+             (base32
+              "04aa9nfdxc475nyj4cl8gkj2grn7v3rkb3hwhbhff5nr88nx4aqq")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:tex-format "latex"))
+    (home-page "https://ctan.org/pkg/margbib")
+    (synopsis "Display bibitem tags in the margins")
+    (description
+     "The package redefines the @code{thebibliography} environment to place
+the citation key into the margin.")
+    (license license:gpl3+)))
+
 (define-public texlive-matapli
   (package
     (name "texlive-matapli")