summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-07 16:38:15 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:51 -0500
commitb715dbac7b917e799e4d520ad6cfd99962d9fc02 (patch)
tree855768c93cfb4fd5000a4cf76904f2f75ea7839e /gnu
parent0955342bf7bc0788c59cdbd4854ab5cb8fa9254a (diff)
downloadguix-b715dbac7b917e799e4d520ad6cfd99962d9fc02.tar.gz
gnu: Add XML-NamespaceSupport.
* gnu/packages/xml.scm (perl-xml-namespacesupport): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 173435d2a5..4f8cafdb71 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -178,6 +179,27 @@ given at XML::Parser creation time.")
 module.")
     (home-page "http://search.cpan.org/~kmacleod/libxml-perl/lib/XML/Parser/PerlSAX.pm")))
 
+(define-public perl-xml-namespacesupport
+  (package
+    (name "perl-xml-namespacesupport")
+    (version "1.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/P/PE/PERIGRIN/"
+                           "XML-NamespaceSupport-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1sklgcldl3w6gn706vx1cgz6pm4y5lfgsjxnfqyk20pilgq530bd"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/XML-NamespaceSupport")
+    (synopsis "XML namespace support class")
+    (description "This module offers a simple to process namespaced XML
+names (unames) from within any application that may need them.  It also helps
+maintain a prefix to namespace URI map, and provides a number of basic
+checks.")
+    (license (package-license perl))))
+
 (define-public perl-xml-simple
   (package
     (name "perl-xml-simple")