summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-04 19:51:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:26 +0200
commitb8fef5d92e1931062c0806ad313c86bf505b7ad1 (patch)
tree693712adf49707bfeb05df1a34611bfb25eb168a /gnu
parentdd9de5760861edf4a094e46d03a8f19e61b4a350 (diff)
downloadguix-b8fef5d92e1931062c0806ad313c86bf505b7ad1.tar.gz
gnu: texlive-latex-blindtext -> texlive-blindtext.
* gnu/packages/tex.scm (texlive-blindtext): New variable.
(texlive-latex-blindtext): Deprecate variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 15 insertions, 11 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8096fd6c67..31433e42d2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4783,20 +4783,22 @@ packages.")
 
 (define-deprecated-package texlive-latex-bigfoot texlive-bigfoot)
 
-(define-public texlive-latex-blindtext
+(define-public texlive-blindtext
   (package
-    (name "texlive-latex-blindtext")
+    (name "texlive-blindtext")
     (version (number->string %texlive-revision))
-    (source (origin
-              (method svn-fetch)
-              (uri (texlive-ref "latex" "blindtext"))
-              (file-name (string-append name "-" version "-checkout"))
-              (sha256
-               (base32
-                "1jrja9b1pzdh9zgv1jh807w4xijqja58n2mqny6dkwicv8qfgbfg"))))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/blindtext/"
+                   "source/latex/blindtext/"
+                   "tex/latex/blindtext/")
+             (base32
+              "1gakawih3mzm5jh01kb44sjpsa4r8c3zwzig5bac37g4ha2vqska")))
+    (outputs '("out" "doc"))
     (build-system texlive-build-system)
-    (arguments '(#:tex-directory "latex/blindtext"))
-    (home-page "https://www.ctan.org/pkg/blindtext")
+    (propagated-inputs
+     (list texlive-tools))
+    (home-page "https://ctan.org/pkg/blindtext")
     (synopsis "Producing 'blind' text for testing")
     (description
      "The package provides the commands @code{\\blindtext} and
@@ -4808,6 +4810,8 @@ the @code{latin} option provides a short \"lorem ipsum\" (for a fuller \"lorem
 ipsum\" text, see the @code{lipsum} package).")
     (license license:lppl)))
 
+(define-deprecated-package texlive-latex-blindtext texlive-blindtext)
+
 (define-public texlive-latex-dinbrief
   (package
     (name "texlive-latex-dinbrief")