summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 01:20:10 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:22 +0300
commitb955cd4a142fd58bfdd46a176b90323aaf552c76 (patch)
tree23af44774c92ba470c72aec6dfa0197a220c7178 /gnu
parent2ab8fad7afc0504ffb5e78108198ed0056624d7d (diff)
downloadguix-b955cd4a142fd58bfdd46a176b90323aaf552c76.tar.gz
gnu: Add go-github-com-coreos-go-semver.
* gnu/packages/golang.scm (go-github-com-coreos-go-semver): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9b469123c9..9a5e8b8f20 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5021,3 +5021,25 @@ escape sequences and color conversions.")
 templates on ANSI compatible terminals.  You can create your own stylesheet or
 use one of our glamourous default themes.")
     (license license:expat)))
+
+(define-public go-github-com-coreos-go-semver
+  (package
+    (name "go-github-com-coreos-go-semver")
+    (version "0.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/coreos/go-semver")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0770h1mpig2j5sbiha3abnwaw8p6dg9i87r8pc7cf6m4kwml3sc9"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/coreos/go-semver"))
+    (home-page "https://github.com/coreos/go-semver/")
+    (synopsis "Semantic versioning library")
+    (description "@code{go-semver} is a semantic versioning library for Go.
+It lets you parse and compare two semantic version strings.")
+    (license license:asl2.0)))