summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-02-23 15:29:01 +0100
committerAndreas Enge <andreas@enge.fr>2023-02-23 15:31:18 +0100
commitcb3332808f42beb4c08970ed792875ee145b715c (patch)
treeed7df559e43bcb3d5ea31ba24f8d313c983b5328 /gnu
parent42810010a9ea1d5a7384c61fd98a957bd1d8055d (diff)
downloadguix-cb3332808f42beb4c08970ed792875ee145b715c.tar.gz
gnu: python-jedi: Update to 0.18.2.
* gnu/packages/python-xyz.scm (python-jedi): Update to 0.18.2.
  [source]: Drop snippet.
  [arguments]: Drop phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 960ff2e433..782fa931f8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18155,7 +18155,7 @@ scans through a file and detects issues.")
 (define-public python-jedi
   (package
     (name "python-jedi")
-    (version "0.18.1")
+    (version "0.18.2")
     (source
      (origin
        (method git-fetch)
@@ -18166,26 +18166,12 @@ scans through a file and detects issues.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "07drmi3ai49jw5n23ibkambcgijqcw073ihypjgxfnks5lv4yqy1"))
-       (modules '((guix build utils)))
-       (snippet
-        ;; Adjust comprehension syntax for Python > 3.8.
-        ;; From <https://github.com/davidhalter/jedi/issues/1824>.
-        '(substitute* "test/completion/lambdas.py"
-           (("if lambda: 3")
-            "if (lambda: 3)")))))
+         "1nhsajmkn3qj32k5z3ymrd3r6dz2aliv2pqb824m5kaib986dm44"))
+       (modules '((guix build utils)))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'fix-completion-test
-           (lambda _
-             ;; This resolves a failure in the 'test_completion' test (see:
-             ;; https://github.com/davidhalter/jedi/issues/1824).
-             ;; TODO: Remove after a new release is made (currently: 0.18.1).
-             (substitute* "test/completion/lambdas.py"
-               (("\\[a for a in \\[1,2\\] if lambda: 3\\]\\[0\\]")
-                "[a for a in [1,2] if (lambda: 3)][0]"))))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?