summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-06-11 22:23:59 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-06-14 13:26:05 +0200
commitcc62eab16314a1c925eb49a4e459ee0a0a36608e (patch)
tree763529c892a35a91708ca70f7a6f0b5ff84c2438 /gnu
parent4fdf3a2e6ef0d635e79aaf912c6997d2cd978835 (diff)
downloadguix-cc62eab16314a1c925eb49a4e459ee0a0a36608e.tar.gz
gnu: Add bbswitch-module.
* gnu/packages/linux.scm (bbswitch-module): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 20c17144a3..f2b35e33c5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1087,6 +1087,29 @@ network adapters.")
 between the CDemu userspace daemon and linux kernel.")
     (license license:gpl2+)))
 
+(define-public bbswitch-module
+  (package
+    (name "bbswitch-module")
+    (version "0.8")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Bumblebee-Project/bbswitch")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1glch4j0x1dzlp2yrb67v2r5jg9609jb6p8m251y78m74advqw0l"))))
+    (build-system linux-module-build-system)
+    (arguments
+     ;; No tests.
+     `(#:tests? #f))
+    (home-page "https://github.com/Bumblebee-Project/bbswitch")
+    (synopsis "Kernel module that disables discrete Nvidia graphics cards")
+    (description "The bbswitch module provides a way to toggle the Nvidia
+graphics card on Optimus laptops.")
+    (license license:gpl2)))
+
 (define-public ddcci-driver-linux
   (package
     (name "ddcci-driver-linux")