summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-21 20:33:56 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 09:38:59 +0200
commitcffb9967fe5037bba4da52438d4d2f57409db637 (patch)
tree114a5df8dbda229dabf20d88b88c65977bacc0a7 /gnu
parentd2dd9d1d2648b81d08f668c0a9dfc300af54d2ac (diff)
downloadguix-cffb9967fe5037bba4da52438d4d2f57409db637.tar.gz
gnu: python-munch: Update to 2.5.0.
* gnu/packages/python-xyz.scm (python-munch): Update to 2.5.0.
  [propagated-inputs]: Add python-six.
  [native-inputs]: Add python-pbr and python-pytest.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d18959889e..6270fee9b9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5742,15 +5742,17 @@ the Texinfo, HTML, and PDF formats.")))
 (define-public python-munch
   (package
     (name "python-munch")
-    (version "2.0.4")
+    (version "2.5.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "munch" version))
         (sha256
          (base32
-          "1cmqg91xnqx8gvnh4pmp0bfl1dfcm65d5p9mg73zz8pkjhx6h80l"))))
+          "1lnvlic9g68hcmgdnv5bzp0nx2bf1kjclj54gx0s7nyl4ipmywrd"))))
     (build-system python-build-system)
+    (native-inputs (list python-pbr python-pytest))
+    (propagated-inputs (list python-six))
     (home-page "https://github.com/Infinidat/munch")
     (synopsis "Dot-accessible dictionary")
     (description "Munch is a dot-accessible dictionary similar to JavaScript