summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-20 18:34:28 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-20 18:40:43 +0200
commitd198eca0b3009d629279caef96e6cf79b913d8e4 (patch)
tree370d3d9d8a89bb5a1edd99a508fff864ebbf67b4 /gnu
parentc82cf31defd786dd9318e25ff80f799e458febc4 (diff)
downloadguix-d198eca0b3009d629279caef96e6cf79b913d8e4.tar.gz
gnu: vis: Fetch sources from git.
* gnu/packages/text-editors.scm (vis)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/text-editors.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 707f815d5d..97aff24aac 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -76,14 +76,15 @@
   (package
     (name "vis")
     (version "0.6")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/martanne/vis/releases"
-                                  "/download/v" version
-                                  "/vis-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0za89vrs97hysgmzpydprgvzsp7yfbr6la1w1c9pad4mqpqs7d4s"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/martanne/vis")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "1zjm89cn3rfq8fxpwp66khy53s6vqlmw6q103qyyvix8ydzxdmsh"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"