summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-09-27 10:55:34 -0400
committerLudovic Courtès <ludo@gnu.org>2023-09-28 11:44:09 +0200
commite082079cb80c34f487ccc5d4fbdd7011f51f29ea (patch)
treea53c30a9f018271b780381b48354dc48de5a18d9 /gnu
parentbe9b7e0f653e27030c402194c7020aea873f30a5 (diff)
downloadguix-e082079cb80c34f487ccc5d4fbdd7011f51f29ea.tar.gz
gnu: ucsim: Use gexps.
* gnu/packages/embedded.scm (ucsim)[arguments]: Use gexp.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/embedded.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 46a9a3a70a..9d07bc4a55 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1604,12 +1604,13 @@ handling communication with eBUS devices connected to a 2-wire bus system
                 "080471wvkjdzxz5j3zdaq1apjcj84ql50kn26b7p4ansixnimml4"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-makefiles
-           (lambda _
-             (substitute* (find-files "." "(\\.mk$|\\.in$)")
-               (("/bin/sh") (which "sh"))))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-makefiles
+            (lambda _
+              (substitute* (find-files "." "(\\.mk$|\\.in$)")
+                (("/bin/sh") (which "sh"))))))))
     (inputs
      (list ncurses))
     (native-inputs