summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2019-11-19 19:49:27 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-21 11:48:30 +0100
commite2293cbbe0cd20ddeb932e6f5616565ab468c087 (patch)
tree030ce32b4b4111f92257bee1e25b22696b4818ce /gnu
parenta2e661e95f8ab2fcb7741198234395b367a794c1 (diff)
downloadguix-e2293cbbe0cd20ddeb932e6f5616565ab468c087.tar.gz
gnu: nmoldyn: New source code location.
* gnu/packages/chemistry.scm (nmoldyn): New source code location.
Following the annoucement of Bitbucket to delete all
Mercurial repositories in June 2020, the source code has
been migrated to GitHub.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/chemistry.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index b6345b9d27..3bdd406a47 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -243,13 +243,14 @@ analogy is that InChI is the bar-code for chemistry and chemical structures.")
     (version "3.0.11")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://bitbucket.org/khinsen/"
-                           "nmoldyn3/downloads/nMOLDYN-"
-                           version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/khinsen/nMOLDYN3")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "1mvmz3lkr217kdrd8cvdr1d82y58wp1403c9rnd943mijgq8xb5a"))))
+         "016h4bqg419p6s7bcx55q5iik91gqmk26hbnfgj2j6zl0j36w51r"))))
     (build-system python-build-system)
     (inputs
      `(("python-matplotlib" ,(with-numpy-1.8 python2-matplotlib))