summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-08 10:00:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-08 10:37:08 +0200
commite3f148a6df106902bbd4bc943a70c46065d80505 (patch)
treef1bd258428ccc3c618fe36645b1460e326f0bfd7 /gnu
parent2ab53074881c98b615b571cd4f7389b329b5774f (diff)
downloadguix-e3f148a6df106902bbd4bc943a70c46065d80505.tar.gz
gnu: Add python-spacy-legacy.
* gnu/packages/machine-learning.scm (python-spacy-legacy): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index c9bc5e8b68..b2429625a2 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -727,6 +727,27 @@ depend on language-specific pre- or post-processing.")
 unsupervised text tokenizer.")
     (license license:asl2.0)))
 
+(define-public python-spacy-legacy
+  (package
+    (name "python-spacy-legacy")
+    (version "3.0.12")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "spacy-legacy" version))
+              (sha256
+               (base32
+                "0x57aw1qgjrzgapsv1cwymqlck2anqm1bisvryhpq7bfkc66wzdk"))))
+    (build-system pyproject-build-system)
+    ;; This package depends on spacy, which depends on this package.
+    (arguments (list #:tests? #false))
+    (native-inputs (list python-pytest))
+    (home-page "https://spacy.io")
+    (synopsis "Legacy registered functions for spaCy backwards compatibility")
+    (description
+     "This package contains legacy registered functions for spaCy backwards
+compatibility.")
+    (license license:expat)))
+
 (define-public shogun
   (package
     (name "shogun")