summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-31 17:22:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-10-31 22:32:53 +0200
commite82b700228debd37a1cb1aff2d23d56f8d2e5768 (patch)
tree0754c3ce35c7538ed17dcb65dd8a5092c789542b /gnu
parentd96a9c7473a6d07747f59eeda7d4085173c25383 (diff)
downloadguix-e82b700228debd37a1cb1aff2d23d56f8d2e5768.tar.gz
gnu: b43-tools: Use make-flags.
* gnu/packages/firmware.scm (b43-tools)[arguments]: Add make-flags.
Use make-flags in custom 'build and 'install phases.  Remove trailing #t
from phases.

Change-Id: I8576351ecd571d191598943a2d143ab3e3e9da09
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/firmware.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 0e638acfae..294bbea184 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -175,6 +175,8 @@ Linux-libre.")
                     (guix build gnu-build-system)
                     (guix build utils))
          #:tests? #f                    ; no tests
+         #:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
+                        ,(string-append "CC=" ,(cc-for-target)))
          #:phases
          (let ((subdirs '("assembler" "disassembler")))
            (modify-phases %standard-phases
@@ -182,24 +184,19 @@ Linux-libre.")
              (add-before 'build 'patch-/bin/true
                (lambda _
                  (substitute* (find-files "." "Makefile")
-                   (("/bin/true") ":"))
-                 #t))
+                   (("/bin/true") ":"))))
              (replace 'build
-               (lambda _
+               (lambda* (#:key (make-flags '()) #:allow-other-keys)
                  (for-each (lambda (dir)
-                             (invoke "make" "-C" dir "CC=gcc"))
-                           subdirs)
-                 #t))
+                             (apply invoke "make" "-C" dir make-flags))
+                           subdirs)))
              (replace 'install
-               (lambda* (#:key outputs #:allow-other-keys)
+               (lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
                  (let ((out (assoc-ref outputs "out")))
                    (mkdir-p (string-append out "/bin"))
                    (for-each (lambda (dir)
-                               (invoke "make" "-C" dir
-                                       (string-append "PREFIX=" out)
-                                       "install"))
-                             subdirs)
-                   #t)))))))
+                               (apply invoke "make" "-C" dir "install" make-flags))
+                             subdirs))))))))
       (home-page
        "https://bues.ch/cms/hacking/misc.html#linux_b43_driver_firmware_tools")
       (synopsis "Collection of tools for the b43 wireless driver")