summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-04 21:15:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:26 +0200
commite9cd94df0dde71a0a495a67d359279e0d26a8f69 (patch)
tree79b0b298b8345ef1f90386945f1e458b71ef4be3 /gnu
parentb8fef5d92e1931062c0806ad313c86bf505b7ad1 (diff)
downloadguix-e9cd94df0dde71a0a495a67d359279e0d26a8f69.tar.gz
gnu: texlive-latex-dinbrief -> texlive-dinbrief.
* gnu/packages/tex.scm (texlive-dinbrief): New variable.
(texlive-latex-dinbrief): Deprecate package.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 31433e42d2..089adfe164 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4812,34 +4812,32 @@ ipsum\" text, see the @code{lipsum} package).")
 
 (define-deprecated-package texlive-latex-blindtext texlive-blindtext)
 
-(define-public texlive-latex-dinbrief
+(define-public texlive-dinbrief
   (package
-    (name "texlive-latex-dinbrief")
+    (name "texlive-dinbrief")
     (version (number->string %texlive-revision))
-    (source (origin
-              (method svn-fetch)
-              (uri (texlive-ref "latex" "dinbrief"))
-              (file-name (string-append name "-" version "-checkout"))
-              (sha256
-               (base32
-                "0lb0kiy8fxzl6cnhcw1sggy6jrjvcd6kj1kkw3k9lkimm388yjz6"))))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/dinbrief/"
+                   "source/latex/dinbrief/"
+                   "tex/latex/dinbrief/")
+             (base32
+              "0l6mmn3y07xglmh3h5f7pnpmyacqb2g6nqgq3q1p6k97kf708c5s")))
+    (outputs '("out" "doc"))
     (build-system texlive-build-system)
     (arguments
-     '(#:tex-directory "latex/dinbrief"
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'remove-generated-file
-           (lambda _
-             (delete-file "dinbrief.drv")
-             #t))
-         (add-after 'unpack 'fix-encoding-error
-           (lambda _
-             (with-fluids ((%default-port-encoding "ISO-8859-1"))
-               (substitute* "dinbrief.dtx"
-                 (("zur Verf.+ung. In der Pr\"aambel")
-                  "zur Verf\"ung. In der Pr\"aambel")))
-             #t)))))
-    (home-page "https://www.ctan.org/pkg/dinbrief")
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-build
+            (lambda _
+              (with-fluids ((%default-port-encoding "ISO-8859-1"))
+                (with-directory-excursion "source/latex/dinbrief"
+                  (delete-file "dinbrief.drv")
+                  (substitute* "dinbrief.dtx"
+                    (("zur Verf.+ung. In der Pr\"aambel")
+                     "zur Verf\"ung. In der Pr\"aambel")))))))))
+    (home-page "https://ctan.org/pkg/dinbrief")
     (synopsis "German letter DIN style")
     (description
      "This package implements a document layout for writing letters according
@@ -4852,6 +4850,8 @@ addition there are example files showing how letters may be created with the
 package.")
     (license license:lppl)))
 
+(define-deprecated-package texlive-latex-dinbrief texlive-dinbrief)
+
 (define-public texlive-latex-draftwatermark
   (package
     (name "texlive-latex-draftwatermark")