summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-06 12:03:11 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:47 -0500
commitebda902fb593b2aee97372151260fd615044bbcb (patch)
treefacfbd367be5e4ee028b5c100d21f77a47c8a8a6 /gnu
parente3cfe3d6d18e6fd9db7341ba3a6c4a21e5fab268 (diff)
downloadguix-ebda902fb593b2aee97372151260fd615044bbcb.tar.gz
gnu: Add Email-Address.
* gnu/packages/mail.scm (perl-email-address): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 752f0a9833..e33d5758e7 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
+;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -69,6 +70,7 @@
   #:use-module (guix download)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system perl)
   #:use-module (guix build-system python))
 
 (define-public mailutils
@@ -648,4 +650,24 @@ facilities for checking incoming mail.")
 mailboxes.  Currently Maildir and IMAP are supported types.")
     (license gpl2+)))
 
+(define-public perl-email-address
+  (package
+    (name "perl-email-address")
+    (version "1.907")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
+                           "Email-Address-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1ai4r149pzjv9dc2vddir8zylj0z1pii93rm4g591lx7avim71hx"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Email-Address")
+    (synopsis "Email address parsing and creation")
+    (description "Email::Address implements a regex-based RFC 2822 parser that
+locates email addresses in strings and returns a list of Email::Address
+objects found.  Alternatively you may construct objects manually.")
+    (license (package-license perl))))
+
 ;;; mail.scm ends here