summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-10-25 18:06:18 +0200
committerAndrew Tropin <andrew@trop.in>2023-10-27 17:28:29 +0400
commiteeb7f8893403066f85d79baae994bfc44d584061 (patch)
treef5c5e128977eaefa12ca7b4af665fa8581b7ade6 /gnu
parentfca99c89b8f29f3156786f6d943748f830279fdc (diff)
downloadguix-eeb7f8893403066f85d79baae994bfc44d584061.tar.gz
gnu: Add emacs-treebundel.
* gnu/packages/emacs-xyz.scm (emacs-treebundel): New variable.

Change-Id: I1b1037b69febd0bab59aae6dd95aeeaa6a5e1e2e
Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 547cb64878..265749d6df 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -795,6 +795,35 @@ configuration language which makes it trivial to write your own themes.")
 Common Lisp or Smalltalk, but for Emacs Lisp.")
       (license license:gpl3+))))
 
+(define-public emacs-treebundel
+  (package
+    (name "emacs-treebundel")
+    (version "0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/purplg/treebundel")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1hk2xnjsr85in48h02xbzi8lsccp36li2bp9v9j0r8qn1bis2vv9"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     (list emacs-compat))
+    (home-page "https://github.com/purplg/treebundel")
+    (synopsis "Bundle related git-worktrees together")
+    (description
+     "This package is used for bundling related git-worktrees from multiple
+repositories together.  This helps switch quickly between repositories and
+ensure you're on the correct branch.  When you're done with your changes, you
+can use the repositories in the workspace and know which ones were modified to
+simplify the process of getting the changes merged in together.  Additionally,
+git metadata is shared between all projects.  You can stash, pop, and pull
+changes in from the same repository in other workspaces thanks to the power of
+git-worktrees.")
+    (license license:expat)))
+
 (define-public emacs-tree-inspector
   (let ((commit "bbb8d2dfe84fbf857fcc1579de5a1324b09a877e"))
     (package