summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-07 13:40:19 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-07 14:23:54 -0500
commitf0569da095fc9da311449a77b36967c8821d67ac (patch)
treeab5777f7a2555faa823b5b68fc4d9d042225fb7b /gnu
parentf8c1dba3d3e375bb97f64a4d29d07035bdb0f2a9 (diff)
downloadguix-f0569da095fc9da311449a77b36967c8821d67ac.tar.gz
gnu: colord-minimal: Move SANE support to colord.
The support is moved to the full 'colord' package.  This reduces
the size of colord-minimal from 467.6 MiB to 391.5 MiB.

* gnu/packages/gnome.scm (colord-minimal) [configure-flags]: Remove
"-Dsane=true".
[inputs]: Move sane-backends to...
(colord) [inputs]: ... here.
[configure-flags]: Add "-Dsane=true".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0b1f30edc8..113227f14d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5597,7 +5597,6 @@ file.")
                                 "-Ddocs=false"
                                 "-Dlocalstatedir=/var"
                                 "-Dman=false"
-                                "-Dsane=true"
                                 "-Dsystemd=false") ;no systemd
       #:phases
       #~(modify-phases %standard-phases
@@ -5639,8 +5638,7 @@ file.")
            libusb
            polkit
            python-wrapper
-           sqlite
-           sane-backends))
+           sqlite))
     (home-page "https://www.freedesktop.org/software/colord/")
     (synopsis "Color management service")
     (description "Colord is a system service that makes it easy to manage,
@@ -5667,6 +5665,7 @@ output devices.")
             (append '("-Dbash_completion=true"
                       "-Ddocs=true"
                       "-Dman=true"
+                      "-Dsane=true"
                       "-Dvapi=true")
                     (fold delete #$flags '("-Dbash_completion=false"
                                            "-Ddocs=false"
@@ -5687,6 +5686,7 @@ output devices.")
                gtk-doc/stable
                libxml2                  ;for XML_CATALOG_FILES
                libxslt
+               sane-backends
                vala)))))                ;for VAPI, needed by simple-scan
 
 (define-public geoclue