summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-09 22:43:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:33 +0200
commitf36563c7b39154558b5fd61deded0be37e1d2f8e (patch)
treeb159f66f408aedcb8b8ebbccfa31b81c62d4f706 /gnu
parenta4d0c9d134f3baff1eb66f0e2b860af74a72864d (diff)
downloadguix-f36563c7b39154558b5fd61deded0be37e1d2f8e.tar.gz
gnu: Add texlive-refstyle.
* gnu/packages/tex.scm (texlive-refstyle): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7b4fe634a1..2ec4bbe5d8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12167,6 +12167,34 @@ allow hyphenation (the corresponding commands in LaTeX, all of whose names are
 lower-case, prevent hyphenation altogether).")
     (license license:lppl1.3c)))
 
+(define-public texlive-refstyle
+  (package
+    (name "texlive-refstyle")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/refstyle/" "source/latex/refstyle/"
+                   "tex/latex/refstyle/")
+             (base32
+              "0ckfm04kfi67babpn3m99nqj4b9r1fs0ivq5m7yz90mz4lqykhbs")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-graphics))
+    (home-page "https://ctan.org/pkg/refstyle")
+    (synopsis "Advanced formatting of cross references")
+    (description
+     "The package provides a consistent way of producing references throughout
+a project.  Enough flexibility is provided to make local changes to a single
+reference.  The user can configure their own setup.  The package offers
+a direct interface to varioref (for use, for example, in large projects such
+as a series of books, or a multivolume thesis written as a series of
+documents), and name references from the nameref package may be incorporated
+with ease.  For large projects such as a series of books or a multi volume
+thesis, written as freestanding documents, a facility is provided to interface
+to the @code{xr} package for external document references.")
+    (license license:lppl)))
+
 (define-public texlive-relsize
   (package
     (inherit (simple-texlive-package