summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-07-02 10:49:17 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-07-02 10:50:55 +0200
commitf4f4ced8dccba6bc0b7c5d5e4c90cdb6488d1faf (patch)
tree3348844163aa910171f227de86127e1c86dbe675 /gnu
parent28de8d258b30f887053d43b2d75a7ed5e2fa2adc (diff)
downloadguix-f4f4ced8dccba6bc0b7c5d5e4c90cdb6488d1faf.tar.gz
gnu: r: Set default pager.
* gnu/packages/statistics.scm (r)[arguments]: Add phase "set-default-pager" to
  avoid "false" as a default pager.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 91d988ebd4..1697ce258e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -58,11 +58,16 @@
                             (assoc-ref %outputs "out")
                             "/lib/R/lib"))
        #:phases
-       (alist-cons-before
-        'check 'set-timezone
-        ;; Some tests require the timezone to be set.
-        (lambda _ (setenv "TZ" "UTC"))
-        %standard-phases)
+       (modify-phases %standard-phases
+         (add-before
+          'configure 'set-default-pager
+          ;; Set default pager to "cat", because otherwise it is "false",
+          ;; making "help()" print nothing at all.
+          (lambda _ (setenv "PAGER" "cat") #t))
+         (add-before
+          'check 'set-timezone
+          ;; Some tests require the timezone to be set.
+          (lambda _ (setenv "TZ" "UTC") #t)))
        #:configure-flags
        '("--with-blas"
          "--with-lapack"