summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-06 13:58:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-06 13:58:05 +0100
commitf5ffcd31c2ea55423ec762e1a5f653cd2af69c85 (patch)
treee2aa847a011f62a5aa7dc1afd0fbd60f117fc415 /gnu
parente20ca244db20d89a93cf4d27d69763b6d3ff1eb9 (diff)
downloadguix-f5ffcd31c2ea55423ec762e1a5f653cd2af69c85.tar.gz
gnu: filtlong: Remove trailing #T from build phases.
* gnu/packages/bioinformatics.scm (filtlong)[arguments]: Remove trailing #T.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e92611ce15..164a2c621a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14332,21 +14332,18 @@ phase + query phase).")
                       (scripts (string-append out "/share/filtlong/scripts")))
                  (install-file "bin/filtlong" bin)
                  (install-file "scripts/histogram.py" scripts)
-                 (install-file "scripts/read_info_histograms.sh" scripts))
-               #t))
+                 (install-file "scripts/read_info_histograms.sh" scripts))))
            (add-after 'install 'wrap-program
              (lambda* (#:key inputs outputs #:allow-other-keys)
                (let* ((out (assoc-ref outputs "out"))
                       (path (getenv "GUIX_PYTHONPATH")))
                  (wrap-program (string-append out
                                               "/share/filtlong/scripts/histogram.py")
-                   `("GUIX_PYTHONPATH" ":" prefix (,path))))
-               #t))
+                   `("GUIX_PYTHONPATH" ":" prefix (,path))))))
            (add-before 'check 'patch-tests
              (lambda _
                (substitute* "scripts/read_info_histograms.sh"
-                 (("awk") (which "gawk")))
-               #t)))))
+                 (("awk") (which "gawk"))))))))
       (inputs
        `(("gawk" ,gawk)                 ;for read_info_histograms.sh
          ("python" ,python-2)           ;required for histogram.py