summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-24 16:20:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-24 16:20:32 +0200
commit0750f344eceb10e8ddd81ed146ae2e1aa897f2d4 (patch)
treec62b413b0a7d520679f67ff94c5de62699f6a071 /gnu
parentd08b3258435254cc6ade95b84a6c53e59cc191e6 (diff)
downloadguix-0750f344eceb10e8ddd81ed146ae2e1aa897f2d4.tar.gz
gnu: Add python-hawkauthlib.
* gnu/packages/python-web.scm (python-hawkauthlib): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6ded2f75ab..c38ccea216 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2649,3 +2649,25 @@ for URL parsing and changing.")
 
 (define-public python2-google-api-client
   (package-with-python2 python-google-api-client))
+
+(define-public python-hawkauthlib
+  (package
+    (name "python-hawkauthlib")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hawkauthlib" version))
+       (sha256
+        (base32
+         "03ai47s4h8nfnrf25shbfvkm1b9n1ccd4nmmj280sg1fayi69zgg"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-requests" ,python-requests)
+       ("python-webob" ,python-webob)))
+    (home-page "https://github.com/mozilla-services/hawkauthlib")
+    (synopsis "Hawk Access Authentication protocol")
+    (description
+     "This is a low-level Python library for implementing Hawk Access Authentication,
+a simple HTTP request-signing scheme.")
+    (license license:mpl2.0)))