summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-09-16 22:17:06 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-09-24 21:42:12 -0400
commit116af86f14f7789831d79815d5b4532afa82058c (patch)
tree5e5870eb3b8b5119d35ffced3cb8a59bbe3d1dcf /gnu
parenta68b45142373dd75bc96f9c4f8151bcd4e972888 (diff)
downloadguix-116af86f14f7789831d79815d5b4532afa82058c.tar.gz
gnu: octave: Add a search path for CURLOPT_CAPATH.
* gnu/packages/maths.scm (octave)[native-search-paths]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 636b485260..b7d669ccea 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1402,6 +1402,13 @@ can solve two kinds of problems:
        ("less" ,less)
        ("ghostscript" ,ghostscript)
        ("gnuplot" ,gnuplot)))
+    ;; Octave code uses this variable to detect directories holding multiple CA
+    ;; certificates to verify peers with.  This is required for the networking
+    ;; functions that require encryption to work properly.
+    (native-search-paths
+     (list (search-path-specification
+            (variable "CURLOPT_CAPATH")
+            (files '("etc/ssl/certs")))))
     (arguments
      `(#:configure-flags
        (list (string-append "--with-shell="