summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-03-29 14:20:20 +0200
committerLeo Famulari <leo@famulari.name>2018-03-30 10:47:57 -0400
commit183ce9884924794677eefca78cf445ada5551260 (patch)
tree35f7fd04d330c1be3abb4b53158b7e9f64f3c25a /gnu
parentf342bb58fef34d2b1364a9fac1d882ffcd329904 (diff)
downloadguix-183ce9884924794677eefca78cf445ada5551260.tar.gz
gnu: Add r-regioner.
* gnu/packages/bioconductor.scm (r-regioner): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index f557dce8e5..09581d9fde 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,7 +22,9 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system r)
-  #:use-module (gnu packages))
+  #:use-module (gnu packages)
+  #:use-module (gnu packages statistics)
+  #:use-module (gnu packages bioinformatics))
 
 (define-public r-hpar
   (package
@@ -40,3 +43,30 @@
     (description "This package provides a simple interface to and data from
 the Human Protein Atlas project.")
     (license license:artistic2.0)))
+
+(define-public r-regioner
+  (package
+    (name "r-regioner")
+    (version "1.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "regioneR" version))
+       (sha256
+        (base32
+         "1vprp3l929hwzmvgskbhawfgnrymwc9n2rxd16rgagnv1dxnjxfp"))))
+    (properties `((upstream-name . "regioneR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-memoise" ,r-memoise)
+       ("r-genomicranges" ,r-genomicranges)
+       ("r-bsgenome" ,r-bsgenome)
+       ("r-rtracklayer" ,r-rtracklayer)
+       ("r-genomeinfodb" ,r-genomeinfodb)
+       ("r-iranges" ,r-iranges)))
+    (home-page "https://bioconductor.org/packages/regioneR/")
+    (synopsis "Association analysis of genomic regions")
+    (description "This package offers a statistical framework based on
+customizable permutation tests to assess the association between genomic
+region sets and other genomic features.")
+    (license license:artistic2.0)))