summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 13:15:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:20 +0100
commit3fa013af78cd228ec9a7ed230fa357239d638284 (patch)
tree53c5953ddc74e9428fb61e554357a3fc823447e6 /gnu
parentb11af07a29a4a642ff8defc335f11c954da4ca26 (diff)
downloadguix-3fa013af78cd228ec9a7ed230fa357239d638284.tar.gz
gnu: perl-net-psyc: Update to 1.3.
* gnu/packages/messaging.scm (perl-net-psyc): Update to 1.3.
[native-inputs]: Add unzip.
[arguments]: Use INVOKE in build phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2a8813cfcf..20bd92394e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1266,7 +1266,7 @@ into existing applications.")
 (define-public perl-net-psyc
   (package
     (name "perl-net-psyc")
-    (version "1.1")
+    (version "1.3")
     (source
      (origin
        (method url-fetch)
@@ -1275,13 +1275,10 @@ into existing applications.")
        (file-name (string-append name "-" version ".zip"))
        (sha256
         (base32
-         "1lw6807qrbmvzbrjn1rna1dhir2k70xpcjvyjn45y35hav333a42"))
-       ;; psycmp3 currently depends on MP3::List and rxaudio (shareware),
-       ;; we can add it back when this is no longer the case.
-       (snippet '(begin
-                   (delete-file "contrib/psycmp3")
-                   #t))))
+         "0vsjclglkwgbyd9m5ad642fyysxw2x725nhq4r2m9pvqaq6s5yf2"))))
     (build-system perl-build-system)
+    (native-inputs
+     `(("unzip" ,unzip)))
     (inputs
      `(("perl-curses" ,perl-curses)
        ("perl-io-socket-ssl" ,perl-io-socket-ssl)))
@@ -1293,8 +1290,7 @@ into existing applications.")
          ;; (leaves out psycion) and says
          ;; "# Just to give you a rough idea". XXX: Fix it upstream.
          (replace 'build
-           (lambda _
-             (zero? (system* "make" "manuals"))))
+           (lambda _ (invoke "make" "manuals")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))