summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-05-02 11:06:08 +0300
committerAlex Kost <alezost@gmail.com>2016-05-04 23:08:39 +0300
commit41447b3199a1455c26639d535c6397d991611274 (patch)
treed9207904ff5a805ace586120e3e7b79efa53d715 /gnu
parentee5f1e520430142a28a2a9e3d50fa61a650d8fe2 (diff)
downloadguix-41447b3199a1455c26639d535c6397d991611274.tar.gz
gnu: libcue: Update to 2.1.0.
* gnu/packages/cdrom.scm (libcue): Update to 2.1.0.
[build-system]: Use 'cmake-build-system' (the upstream moved to it).
[native-inputs]: Add 'bison' and 'flex'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cdrom.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 4eff2d5cb0..70772bf157 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24,10 +25,13 @@
   #:use-module (guix download)
   #:use-module (guix packages)
   #:use-module ((guix licenses) #:select (lgpl2.1+ gpl2 gpl2+ gpl3+))
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages acl)
+  #:use-module (gnu packages bison)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages flex)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages man)
@@ -230,16 +234,20 @@ capacity is user-selectable.")
 (define-public libcue
   (package
     (name "libcue")
-    (version "1.4.0")
+    (version "2.1.0")
     (source (origin
              (method url-fetch)
-             (uri (string-append "https://github.com/lipnitsk/libcue/releases/"
-                                 "download/v" version "/libcue-"
-                                 version ".tar.bz2"))
+             (uri (string-append
+                   "https://github.com/lipnitsk/libcue/archive/v"
+                   version ".tar.gz"))
+             (file-name (string-append name "-" version ".tar.gz"))
              (sha256
               (base32
-               "17kjd7rjz1bvfn44n3n2bjb7a1ywd0yc0g4sqp5ihf9b5bn7cwlb"))))
-    (build-system gnu-build-system)
+               "1fradl3dx0pyy9rn1a0gak9gzgg40wax61f2s00zks7rwl0xv398"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("bison" ,bison)
+       ("flex" ,flex)))
     (home-page "https://github.com/lipnitsk/libcue")
     (synopsis "C library to parse cue sheets")
     (description "Libcue is a C library to parse so-called @dfn{cue sheets}