summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 09:28:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:18 +0100
commit492ee4f83bbb803e0135cc42d8a0d80d5e1787ad (patch)
treef251007fadfe068b71eb265de52559a9a377338a /gnu
parentace73a93cdb70e2d470387516f22465d170c2d14 (diff)
downloadguix-492ee4f83bbb803e0135cc42d8a0d80d5e1787ad.tar.gz
gnu: coq-mathcomp: Use INVOKE.
* gnu/packages/coq.scm (coq-mathcomp)[arguments]: Unconditionally return #T
from build phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/coq.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 2d603f91d5..076aa7f7b9 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -295,15 +295,14 @@ assistant.")
        (modify-phases %standard-phases
          (delete 'configure)
          (add-before 'build 'chdir
-           (lambda _
-             (chdir "mathcomp")))
+           (lambda _ (chdir "mathcomp") #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (setenv "COQLIB" (string-append (assoc-ref outputs "out") "/lib/coq/"))
-             (zero? (system* "make" "-f" "Makefile.coq"
-                             (string-append "COQLIB=" (assoc-ref outputs "out")
-                                            "/lib/coq/")
-                             "install")))))))
+             (invoke "make" "-f" "Makefile.coq"
+                     (string-append "COQLIB=" (assoc-ref outputs "out")
+                                    "/lib/coq/")
+                     "install"))))))
     (home-page "https://math-comp.github.io/math-comp/")
     (synopsis "Mathematical Components for Coq")
     (description "Mathematical Components for Coq has its origins in the formal