summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-06-30 10:56:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-06-30 10:56:57 +0300
commit5fc4df0cb5a33a426ef629870ee7b59341079bc5 (patch)
tree477c28b861a8c468dd3d978ae0bcc12d22bcc506 /gnu
parent9b1c1ea12962a9442c452ed2b9ab2e771ea60b18 (diff)
downloadguix-5fc4df0cb5a33a426ef629870ee7b59341079bc5.tar.gz
gnu: owncloud-client: Remove some bundled libs.
* gnu/packages/owncloud.scm (owncloud-client)[source]: Add a snippet
removing some of the 3rd party projects.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/owncloud.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/owncloud.scm b/gnu/packages/owncloud.scm
index cfb5e2c149..f755df4f0b 100644
--- a/gnu/packages/owncloud.scm
+++ b/gnu/packages/owncloud.scm
@@ -41,7 +41,20 @@
        (uri (string-append "https://download.owncloud.com/desktop/stable/"
                            "owncloudclient-" version ".tar.xz"))
        (sha256
-        (base32 "0m0pxv12w72qqgxim9fh8w3bgkgnhpjyay8ldll3nnzq1jmhk09n"))))
+        (base32 "0m0pxv12w72qqgxim9fh8w3bgkgnhpjyay8ldll3nnzq1jmhk09n"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; only allows bundled libcrashreporter-qt
+           (delete-file-recursively "src/3rdparty/libcrashreporter-qt")
+           ;; we already package qtkeychain and sqlite
+           (delete-file-recursively "src/3rdparty/qtkeychain")
+           (delete-file-recursively "src/3rdparty/sqlite3")
+           ;; qjson is packaged, qprogessindicator, qlockedfile, qtokenizer and
+           ;; qtsingleapplication have not yet been packaged, but all are
+           ;; explicitly used from the 3rdparty folder during build.
+           ;; We can also remove the macgoodies folder
+           (delete-file-recursively "src/3rdparty/qtmacgoodies")))))
     (build-system cmake-build-system)
     (arguments
      `(#:phases