summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-11 13:59:54 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-11 13:59:54 +0800
commit6d889daf2a8162a248da0b654d69d3c7346a4ca0 (patch)
tree4e6f576547bc4b56618151eff136e01916232669 /gnu
parentd1f9e45e5d55d6ccc78bd26bf56091bb83c19bfa (diff)
downloadguix-6d889daf2a8162a248da0b654d69d3c7346a4ca0.tar.gz
gnu: libcap: Add $libdir to the RUNPATH of executables.
* gnu/packages/linux.scm (libcap)[arguments]: Set LDFLAGS to
  '-Wl,-rpath=...' in Make.Rules.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e2b8301fef..18f220ef68 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -982,7 +982,15 @@ advanced aspects of IP configuration (iptunnel, ipmaddr).")
               (base32
                "07vjhkznm82p8dm4w6j8mmg7h5c70lp5s9bwwfdmgwpbixfydjp1"))))
     (build-system gnu-build-system)
-    (arguments '(#:phases (alist-delete 'configure %standard-phases)
+    (arguments '(#:phases
+                 (modify-phases %standard-phases
+                   (replace 'configure
+                            ;; Add $libdir to the RUNPATH of executables.
+                            (lambda _
+                              (substitute* "Make.Rules"
+                                (("LDFLAGS := #-g")
+                                 (string-append "LDFLAGS := -Wl,-rpath="
+                                                %output "/lib"))))))
                  #:tests? #f                      ; no 'check' target
                  #:make-flags (list "lib=lib"
                                     (string-append "prefix="