summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Sassmannshausen <alex@pompo.co>2016-06-29 16:43:15 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-02 16:24:35 +0200
commit7640c62dd2863fdc04115ccb9d7c30c079b26ea8 (patch)
treefc6b0e22a44c4f9f9ba7208cf2d83dd487262ec5 /gnu
parentd209710bd4a1ec621e4ea5ecda158dfa389e9e85 (diff)
downloadguix-7640c62dd2863fdc04115ccb9d7c30c079b26ea8.tar.gz
gnu: Add perl-file-zglob.
* gnu/packages/perl.scm (perl-file-zglob): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm45
1 files changed, 31 insertions, 14 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6a991975de..1a0c8783d1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -988,26 +988,23 @@ options.")
   (package
     (name "perl-config-ini")
     (version "0.025")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://cpan.metacpan.org/authors/id/R/RJ/RJBS/Config-INI-"
-             version
-             ".tar.gz"))
-       (sha256
-        (base32
-         "0clphq6a17chvb663fvjnxqvyvh26g03x0fl4bg9vy4ibdnzg2v2"))))
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/R/RJ/RJBS/Config-INI-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0clphq6a17chvb663fvjnxqvyvh26g03x0fl4bg9vy4ibdnzg2v2"))))
     (build-system perl-build-system)
     (inputs
      `(("perl-mixin-linewise" ,perl-mixin-linewise)
        ("perl-perlio-utf8_strict" ,perl-perlio-utf8_strict)
        ("perl-sub-exporter" ,perl-sub-exporter)))
-    (home-page
-     "http://search.cpan.org/dist/Config-INI")
+    (home-page "http://search.cpan.org/dist/Config-INI")
     (synopsis "Simple .ini-file format reader and writer")
-    (description "Config::INI provides a module that facilates the reading and
-writing of .ini style configuration files.")
+    (description "@code{Config::INI} is a module that facilates the reading
+and writing of @code{.ini}-style configuration files.")
     (license (package-license perl))))
 
 (define-public perl-context-preserve
@@ -2466,6 +2463,26 @@ shell.")
                               "File-Which-" version))
     (license (package-license perl))))
 
+(define-public perl-file-zglob
+  (package
+    (name "perl-file-zglob")
+    (version "0.11")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/T/TO/TOKUHIROM/File-Zglob-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "16v61rn0yimpv5kp6b20z2f1c93n5kpsyjvr0gq4w2dc43gfvc8w"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/File-Zglob")
+    (synopsis "Extended Unix style glob functionality")
+    (description "@code{File::Zglob} provides a traditional Unix @code{glob}
+functionality; it returns a list of file names that match the given pattern.
+For instance, it supports the @code{**/*.pm} form.")
+    (license (package-license perl))))
+
 (define-public perl-getopt-long-descriptive
   (package
     (name "perl-getopt-long-descriptive")