summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-17 15:19:14 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-19 16:43:31 -0500
commit92503917f70218df6d3d3553e4fa3b85eed1a832 (patch)
treebb979dcca0a72a74aee4e75f2261ce339c9eb6f1 /gnu
parent040a52fd75bce0b45b36434ead1cdc393611bcb9 (diff)
downloadguix-92503917f70218df6d3d3553e4fa3b85eed1a832.tar.gz
gnu: Add Tie-IxHash.
* gnu/packages/perl.scm (perl-tie-ixhash): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b6940215e2..8fc8ff66db 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3617,6 +3617,28 @@ letters, the pronunciation expressed by the text in some other writing
 system.")
     (license (package-license perl))))
 
+(define-public perl-tie-ixhash
+  (package
+  (name "perl-tie-ixhash")
+  (version "1.23")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (string-append "mirror://cpan/authors/id/C/CH/CHORNY/"
+                          "Tie-IxHash-" version ".tar.gz"))
+      (sha256
+        (base32
+          "0mmg9iyh42syal3z1p2pn9airq65yrkfs66cnqs9nz76jy60pfzs"))))
+  (build-system perl-build-system)
+  (home-page "http://search.cpan.org/dist/Tie-IxHash")
+  (synopsis "Ordered associative arrays for Perl")
+  (description "This Perl module implements Perl hashes that preserve the
+order in which the hash elements were added. The order is not affected when
+values corresponding to existing keys in the IxHash are changed. The elements
+can also be set to any arbitrary supplied order. The familiar perl array
+operations can also be performed on the IxHash.")
+  (license (package-license perl))))
+
 (define-public perl-time-local
   (package
     (name "perl-time-local")