summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-26 22:59:40 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-29 00:23:27 +0100
commit94a1eb96d32fcce97ee5d9440ecffe22f7555cd5 (patch)
tree046a9afd0bebfee3add786ae115c1b1de39273bd /gnu
parent59cd0ba4abd7df1079cc9b1c92b5a363c2e25ef4 (diff)
downloadguix-94a1eb96d32fcce97ee5d9440ecffe22f7555cd5.tar.gz
gnu: fbcat, slepc: Use INVOKE.
* gnu/packages/linux.scm (fbcat)[arguments]: Substitute INVOKE for
SYSTEM*.
* gnu/packages/maths.scm (slepc)[arguments]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm5
-rw-r--r--gnu/packages/maths.scm2
2 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 869b4f752b..9a410b0b10 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4587,8 +4587,9 @@ relevant @file{/dev/vcs*} file(s).")
          (delete 'configure)            ; no configure script
          (add-after 'build 'build-documentation
            (lambda* (#:key make-flags #:allow-other-keys)
-             (zero? (apply system* "make" "-C" "doc"
-                           make-flags))))
+             (apply invoke "make" "-C" "doc"
+                    make-flags)
+             #t))
          (add-after 'build 'qualify-references
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((pnmtopng (assoc-ref inputs "pnmtopng"))
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d4e9914e18..90beb6c724 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1647,7 +1647,7 @@ scientific applications modeled by partial differential equations.")
               (format #t "configure flags: ~s~%" flags)
               (setenv "SLEPC_DIR" (getcwd))
               (setenv "PETSC_DIR" (assoc-ref inputs "petsc"))
-              (zero? (apply system* "./configure" flags)))))
+              (invoke "./configure" flags))))
          (add-after 'install 'delete-doc
           ;; TODO: SLEPc installs HTML documentation alongside headers in
           ;; $out/include.  We'd like to move them to share/doc, but delete