summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-05-20 14:55:26 -0400
committerMark H Weaver <mhw@netris.org>2015-05-20 16:07:09 -0400
commit3a6fb858ad95dd422b2519d5862d5db61deeb2a5 (patch)
tree6fd9a7a6242a14ae02c26dfeb96c655286681b3d /gnu
parent87158e851ffc9a256350780c31266d680dba7a18 (diff)
downloadguix-3a6fb858ad95dd422b2519d5862d5db61deeb2a5.tar.gz
gnu: bitlbee: Update to 3.4.
* gnu/packages/patches/bitlbee-configure-doc-fix.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/messaging.scm (bitlbee): Update to 3.4.  Add patch.
  [inputs]: Remove 'zlib'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm6
-rw-r--r--gnu/packages/patches/bitlbee-configure-doc-fix.patch15
2 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index fd857b1ec3..99c5bdb0ff 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -86,20 +86,20 @@ providing:
 (define-public bitlbee
   (package
     (name "bitlbee")
-    (version "3.2.2")
+    (version "3.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://get.bitlbee.org/src/bitlbee-"
                                   version ".tar.gz"))
               (sha256
-               (base32 "13jmcxxgli82wb2n4hs091159xk8rgh7nb02f478lgpjh6996f5s"))))
+               (base32 "0plx4dryf8i6hz7vghg84z5f6w6rkw1l8ckl4c4wh5zxpd3ddfnf"))
+              (patches (list (search-patch "bitlbee-configure-doc-fix.patch")))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("check" ,check)))
     (inputs `(("glib" ,glib)
               ("libotr" ,libotr)
               ("gnutls" ,gnutls)
-              ("zlib" ,zlib)  ; Needed to satisfy "pkg-config --exists gnutls"
               ("python" ,python-2)
               ("perl" ,perl)))
     (arguments
diff --git a/gnu/packages/patches/bitlbee-configure-doc-fix.patch b/gnu/packages/patches/bitlbee-configure-doc-fix.patch
new file mode 100644
index 0000000000..ade0b7f25c
--- /dev/null
+++ b/gnu/packages/patches/bitlbee-configure-doc-fix.patch
@@ -0,0 +1,15 @@
+Fix the check for the prebuilt helpfile when xsltproc is not available.
+
+--- bitlbee-3.4/configure.orig	2015-03-25 18:09:10.000000000 -0400
++++ bitlbee-3.4/configure	2015-05-20 14:51:33.627975970 -0400
+@@ -650,8 +650,8 @@
+ 
+ if [ "$doc" = "1" ]; then
+ 	if [ ! -e doc/user-guide/help.txt ] && \
+-	     ! type xmlto > /dev/null 2> /dev/null || \
+-	     ! type xsltproc > /dev/null 2> /dev/null
++	     (! type xmlto > /dev/null 2> /dev/null || \
++	      ! type xsltproc > /dev/null 2> /dev/null)
+ 	then
+ 		echo
+ 		echo 'WARNING: Building from an unreleased source tree without prebuilt helpfile.'