summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2016-01-11 13:27:31 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-01-14 09:12:23 -0500
commit210bf49754f397e229a4e1a81f8d16a52dcdef7a (patch)
tree192defb70f7ae20049ee9ff666a18070b7f7feb8 /gnu
parentb3667afbd2c40e3303816452afdfcebefa9d2ea8 (diff)
downloadguix-210bf49754f397e229a4e1a81f8d16a52dcdef7a.tar.gz
gnu: Add python-texttable.
* gnu/packages/python.scm (python-texttable, python2-texttable): New
variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e1009cc2ca..4081362f2f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6657,3 +6657,25 @@ the standard library.")
 
 (define-public python2-contextlib2
   (package-with-python2 python-contextlib2))
+
+(define-public python-texttable
+  (package
+    (name "python-texttable")
+    (version "0.8.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "texttable" version))
+       (sha256
+        (base32
+         "0bkhs4dx9s6g7fpb969hygq56hyz4ncfamlynw72s0n6nqfbd1w5"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f)) ; no tests
+    (home-page "https://github.com/foutaise/texttable/")
+    (synopsis "Python module for creating simple ASCII tables")
+    (description "Texttable is a Python module for creating simple ASCII
+tables.")
+    (license lgpl2.1+)))
+
+(define-public python2-texttable
+  (package-with-python2 python-texttable))