summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-02 15:17:08 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-02 15:17:08 +0100
commit55a5674f21d1adf4a8b2d0c67f6a6ba51ebb4027 (patch)
treeec79d9578e2586b3ff616fd9ee56b1894780fbd0 /gnu
parent08928e5752ea876bd5db22b4dfec43ce792d3eb6 (diff)
downloadguix-55a5674f21d1adf4a8b2d0c67f6a6ba51ebb4027.tar.gz
gnu: make-bootstrap: Add C++ header files to the bootstrap GCC.
* gnu/packages/make-bootstrap.scm (%gcc-stripped): Add $gcc/include/c++.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/make-bootstrap.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 708cb39bb2..c79bcc2cf3 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -429,6 +429,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
          (let* ((out        (assoc-ref %outputs "out"))
                 (bindir     (string-append out "/bin"))
                 (libdir     (string-append out "/lib"))
+                (includedir (string-append out "/include"))
                 (libexecdir (string-append out "/libexec"))
                 (gcc        (assoc-ref %build-inputs "gcc")))
            (copy-recursively (string-append gcc "/bin") bindir)
@@ -444,6 +445,11 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                              libexecdir)
            (for-each remove-store-references
                      (find-files libexecdir ".*"))
+
+           ;; Starting from GCC 4.8, helper programs built natively
+           ;; (‘genchecksum’, ‘gcc-nm’, etc.) rely on C++ headers.
+           (copy-recursively (string-append gcc "/include/c++")
+                             (string-append includedir "/c++"))
            #t))))
     (inputs `(("gcc" ,%gcc-static)))))