summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-05-01 21:38:05 +0200
committerAndreas Enge <andreas@enge.fr>2013-05-01 21:38:05 +0200
commitd515cb555cf88893db6622a12c7be54ef2ef178a (patch)
treeb96e84cf492414eef71c4fb9fd03f4c417e526b0 /gnu
parent0734a9a8131525d6da2e7bf802402dc0350eda98 (diff)
downloadguix-d515cb555cf88893db6622a12c7be54ef2ef178a.tar.gz
gnu: xorg: Have perl paths set automatically.
* gnu/packages/xorg.scm (xkeyboard-config): Drop special handling of perl paths.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 93e2da5d48..a1373c47e0 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3628,21 +3628,8 @@ tracking.")
       `(("gettext" ,gnu:gettext)
         ("intltool" ,intltool)
         ("libx11" ,libx11)
-        ;; required to set PERL5LIB, although it is propagated by intltool
-        ("perl-xml-parser" ,perl-xml-parser)
         ("pkg-config" ,pkg-config)
         ("xkbcomp" ,xkbcomp)))
-    (arguments
-      `(#:phases
-         (alist-replace
-          'configure
-          (lambda* (#:key inputs #:allow-other-keys #:rest args)
-            (let ((configure (assoc-ref %standard-phases 'configure))
-                  (perl-xml-parser (assoc-ref inputs "perl-xml-parser")))
-              ;; FIXME: This should be done more centrally.
-              (setenv "PERL5LIB" (string-append perl-xml-parser "/lib/perl5/site_perl"))
-              (apply configure args)))
-         %standard-phases)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")