summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-07-12 15:16:44 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-08 22:08:17 +1000
commit085f59a50e009a97b2ae43c0f768e84ec823afb6 (patch)
tree306799d593ebdd6a6ecf45451b9438fd82c44070 /gnu
parent5e2b27b045292250c8fc22fd4c188003d3eaffcf (diff)
downloadguix-085f59a50e009a97b2ae43c0f768e84ec823afb6.tar.gz
gnu: Add perl-graph.
* gnu/packages/perl.scm (perl-graph): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 5df8281cd7..ffb7c1fd30 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2551,6 +2551,27 @@ vaguely inspired by John Ousterhout's Tk_ParseArgv.")
                               "Getopt-Tabular-" version))
     (license (package-license perl))))
 
+(define-public perl-graph
+  (package
+    (name "perl-graph")
+    (version "0.9704")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/J/JH/JHI/Graph-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "099a1gca0wj5zs0cffncjqp2mjrdlk9i6325ks89ml72gfq8wpij"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Graph")
+    (synopsis "Graph data structures and algorithms")
+    (description "This is @code{Graph}, a Perl module for dealing with graphs,
+the abstract data structures.")
+    (license (package-license perl))))
+
 (define-public perl-guard
   (package
     (name "perl-guard")