summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-02-08 16:29:06 +0300
committerAlex Kost <alezost@gmail.com>2016-02-10 01:34:17 +0300
commit2b0e43003ccc1f00e45cde088296168fb7c90bdd (patch)
treed7b8ee6782a5637645c073faf40d07ae37f3131e /gnu
parent2c04e2eec8bf250d1e928b7c8b1e60424b0b32fa (diff)
downloadguix-2b0e43003ccc1f00e45cde088296168fb7c90bdd.tar.gz
gnu: Add emacs-with-editor.
* gnu/packages/emacs.scm (emacs-with-editor): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fc940eb487..8084bb3c6b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -349,6 +349,31 @@ when typing parentheses directly or commenting out code line by line.")
 configuration files, such as .gitattributes, .gitignore, and .git/config.")
     (license license:gpl3+)))
 
+(define-public emacs-with-editor
+  (package
+    (name "emacs-with-editor")
+    (version "2.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/magit/with-editor/archive/v"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "19gb381z61l2icg5v5pymgi1a11g3zdp5aysl2j5fh7fxxg4d4c0"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)))
+    (home-page "https://github.com/magit/with-editor")
+    (synopsis "Emacs library for using Emacsclient as EDITOR")
+    (description
+     "This package provides an Emacs library to use the Emacsclient as
+@code{$EDITOR} of child processes, making sure they know how to call home.
+For remote processes a substitute is provided, which communicates with Emacs
+on stdout instead of using a socket as the Emacsclient does.")
+    (license license:gpl3+)))
+
 (define-public magit
   (package
     (name "magit")