summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-08-14 09:47:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-08-15 10:42:08 +0300
commit6cc83b68cb1b43866327e3f41c4330210ac9a67f (patch)
treefe539757588578e58f8f88cb6a3ff076cf548d71 /gnu
parent6d2b94f22543ff63750c431be2af69dc85f6940e (diff)
downloadguix-6cc83b68cb1b43866327e3f41c4330210ac9a67f.tar.gz
gnu: gnu-make: Use 'modify-phases'.
* gnu/packages/base.scm (gnu-make)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 2799b28016..e7b6589203 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -339,16 +339,16 @@ functionality beyond that which is outlined in the POSIX standard.")
    (inputs `(("guile" ,guile-2.0)))
    (outputs '("out" "debug"))
    (arguments
-    '(#:phases (alist-cons-before
-                'build 'set-default-shell
-                (lambda* (#:key inputs #:allow-other-keys)
-                  ;; Change the default shell from /bin/sh.
-                  (let ((bash (assoc-ref inputs "bash")))
-                    (substitute* "job.c"
-                      (("default_shell =.*$")
-                       (format #f "default_shell = \"~a/bin/bash\";\n"
-                               bash)))))
-                %standard-phases)))
+    '(#:phases
+      (modify-phases %standard-phases
+        (add-before 'build 'set-default-shell
+          (lambda* (#:key inputs #:allow-other-keys)
+            ;; Change the default shell from /bin/sh.
+            (let ((bash (assoc-ref inputs "bash")))
+              (substitute* "job.c"
+                (("default_shell =.*$")
+                 (format #f "default_shell = \"~a/bin/bash\";\n"
+                         bash)))))))))
    (synopsis "Remake files automatically")
    (description
     "Make is a program that is used to control the production of