summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 21:59:08 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:36 -0500
commit97abe268ab54c2aa6aad9b9e068ace9f8ab87988 (patch)
treeff6ab29b715de128330f7071904f838537d91d83 /gnu
parent2fc5f186801ab8e989b6d8e97f37455af96969fd (diff)
downloadguix-97abe268ab54c2aa6aad9b9e068ace9f8ab87988.tar.gz
gnu: Add python-zope-interface.
* gnu/packages/python.scm (python-zope-interface,
  python2-zope-interface): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 25f5c6eeeb..fbefd9598f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6033,3 +6033,29 @@ dispatching systems can be built.")
 
 (define-public python2-zope-event
   (package-with-python2 python-zope-event))
+
+(define-public python-zope-interface
+  (package
+    (name "python-zope-interface")
+    (version "4.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://pypi.python.org/packages/source/z"
+                           "/zope.interface/zope.interface-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0ks8h73b2g4bkad821qbv0wzjppdrwys33i7ka45ik3wxjg1l8if"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-zope-event" ,python-zope-event)))
+    (home-page "https://github.com/zopefoundation/zope.interface")
+    (synopsis "Python implementation of the \"design by contract\"
+methodology")
+    (description "Zope.interface provides an implementation of \"object
+interfaces\" for Python.  Interfaces are a mechanism for labeling objects as
+conforming to a given API or contract.")
+    (license zpl2.1)))
+
+(define-public python2-zope-interface
+  (package-with-python2 python-zope-interface))