summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-10 19:34:06 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-12 20:36:44 +0800
commitc5c2f9bbb0d47230ae2e4052ef2ddcc3e9dc704c (patch)
treeb5d15b63486db6b012f1684d2a1924d6619d6331 /gnu
parent3b3a7fe78ca1336ad0130eefaf2f01e5a7352a0e (diff)
downloadguix-c5c2f9bbb0d47230ae2e4052ef2ddcc3e9dc704c.tar.gz
gnu: Add xfce4-appfinder.
* gnu/packages/xfce.scm (xfce4-appfinder): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xfce.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index ceceba65f8..5ea41c7590 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -264,3 +264,29 @@ management D-Bus specification.")
 applications menu, workspace switcher and more.")
     ;; Libraries are under LGPLv2.1+, and programs under GPLv2+.
     (license (list gpl2+ lgpl2.1+))))
+
+(define-public xfce4-appfinder
+  (package
+    (name "xfce4-appfinder")
+    (version "4.10.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/xfce/"
+                                  (version-major+minor version)
+                                  "/src/" name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0falckrziw8m1a72nxd7fqq84r3xfbrb6lv35flsca346rzawah4"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("intltool" ,intltool)))
+    (inputs
+     `(("garcon" ,garcon)
+       ("libxfce4ui" ,libxfce4ui)))
+    (home-page "http://www.xfce.org/")
+    (synopsis "Xfce application finder")
+    (description
+     "Application finder for Xfce, it will show the applications installed on
+your system in categories, so you can quickly find and launch them.")
+    (license gpl2+)))