summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-11-30 03:10:35 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-01 16:11:57 +0100
commitb59a8fd49afa79bb9c3bf5e71dce6f3eec2a0808 (patch)
tree4dce0cc6b58ebd1d7a3495b5de1f9913becb94fd /gnu
parent3f691f71965f35891932a32b54a8ca4c32e3221f (diff)
downloadguix-b59a8fd49afa79bb9c3bf5e71dce6f3eec2a0808.tar.gz
gnu: Add mtr.
* gnu/packages/networking.scm (mtr): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1f4906b7b5..755f76b153 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1536,3 +1536,34 @@ at the IP layer and link layer, as well as a host of supplementary
 functionality.  Using libnet, quick and simple packet assembly applications
 can be whipped up with little effort.")
     (license license:bsd-2)))
+
+(define-public mtr
+  (package
+    (name "mtr")
+    (version "0.92")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "ftp://ftp.bitwizard.nl/" name "/"
+                           name "-" version ".tar.gz"))
+       (sha256
+        (base32 "10j3ds3p27jygys4x08kj8fi3zlsgiv72xsfazkah6plwawrv5zj"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libcap" ,libcap)
+       ("ncurses" ,ncurses)))
+    (native-inputs
+     ;; The 0.92 release tarball still requires the ‘autoheader’ tool.
+     `(("autoconf" ,autoconf)))
+    (arguments
+     `(#:tests? #f))                    ; tests require network access
+    (home-page "https://www.bitwizard.nl/mtr/")
+    (synopsis "Network diagnostic tool")
+    (description
+     "@dfn{mtr} (My TraceRoute) combines the functionality of the
+@command{traceroute} and @command{ping} programs in a single network diagnostic
+tool.  @command{mtr} uses ICMP ECHO packets to detect intermediate routers (or
+@dfn{hops}) between the local host and a user-specified destination.  It then
+continually measures the response time and packet loss at each hop, and
+displays the results in real time.")
+    (license license:gpl2+)))