summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-16 10:54:07 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-16 10:54:07 +0200
commit457e528eb910225d55b08f200fabe29c1eebbb52 (patch)
treed4d2a757b11b04464bf5e80d95174b7d7e00daf1 /gnu
parentf2feb0ce7c9a846cdb0fae2ba24f98fe0b681a9e (diff)
downloadguix-457e528eb910225d55b08f200fabe29c1eebbb52.tar.gz
gnu: ffmpeg: Allow tests to run from the build tree.
* gnu/packages/video.scm (ffmpeg)[arguments]: Add 'set-ld-library-path'
  phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 693a8251f8..114ad7e61b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -411,6 +411,16 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
                       "--disable-mipsdspr1"
                       "--disable-mipsdspr2"
                       "--disable-mipsfpu")))))
+         (add-before
+          'check 'set-ld-library-path
+          (lambda _
+            ;; Allow $(top_builddir)/ffmpeg to find its dependencies when
+            ;; running tests.
+            (let* ((dso  (find-files "." "\\.so$"))
+                   (path (string-join (map dirname dso) ":")))
+              (format #t "setting LD_LIBRARY_PATH to ~s~%" path)
+              (setenv "LD_LIBRARY_PATH" path)
+              #t)))
          (add-after
           'strip 'add-lib-to-runpath
           (lambda* (#:key outputs #:allow-other-keys)