summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-12-02 00:57:37 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-12-02 00:57:37 +0100
commit62c2cef05c9758e09411d6787cf135ee85d303d9 (patch)
treeb6d74d655ef785ebf3c46361813ccff3e0ed1df8 /gnu
parentb6aeae6e980198ec182e9eb0ac953f750e34d7bd (diff)
downloadguix-62c2cef05c9758e09411d6787cf135ee85d303d9.tar.gz
gnu: python-aiohttp: Update to 3.4.4.
* gnu/packages/python-web.scm (python-aiohttp): Update to 3.4.4.
[native-inputs] Remove test-related inputs since tests are not run.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 55b8942ac9..ecd141efca 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -68,22 +68,17 @@
 (define-public python-aiohttp
   (package
     (name "python-aiohttp")
-    (version "3.1.3")
+    (version "3.4.4")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "aiohttp" version))
        (sha256
         (base32
-         "1b888lggmyf2d08rfayq9khszzc0pav1z70ssc0b4d9kkr4g1klz"))))
+         "1ykm6kdjkrg556j0zd7dx2l1rsrbh0d9g27ivr6dmaahz9pyrbsi"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f))                    ;FIXME: 2 errors, 2084 passed
-    (native-inputs
-     `(("python-async-generator" ,python-async-generator)
-       ("python-pytest" ,python-pytest)
-       ("python-pytest-capturelog" ,python-pytest-capturelog)
-       ("python-pytest-mock" ,python-pytest-mock)))
+     `(#:tests? #f))                    ;missing pytest-timeout
     (propagated-inputs
      `(("python-aiodns" ,python-aiodns)
        ("python-async-timeout" ,python-async-timeout)