summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:13 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:59 -0400
commit7e06c4aa98a3d240c8e8847e825c1a2f780e1fbe (patch)
tree6dc2c3b7a8b2501fad90be5059496ebd9d136df4 /gnu
parent25b3bdb5ffed180f1c7e393f3287d1e5d0364be7 (diff)
downloadguix-7e06c4aa98a3d240c8e8847e825c1a2f780e1fbe.tar.gz
gnu: Add ghc-options-bootstrap.
* gnu/packages/haskell.scm (ghc-options-bootstrap): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 100efd65aa..51cfa74a21 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7224,4 +7224,30 @@ which can't be decoded in the current locale encoding.")
 spirit to POSIX shells.  Shelly is originally forked  from the Shellish package.")
     (license license:bsd-3)))
 
+;; See ghc-system-filepath-bootstrap, chell and chell-quickcheck are required for tests.
+(define ghc-options-bootstrap
+  (package
+    (name "ghc-options-bootstrap")
+    (version "1.2.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/options/options-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "0qjs0v1ny52w51n5582d4z8wy9h6n0zw1xb5dh686ff5wadflgi8"))))
+    (build-system haskell-build-system)
+    (arguments
+     `(#:tests? #f))
+    (inputs
+     `(("ghc-monads-tf" ,ghc-monads-tf)))
+    (home-page "https://john-millikin.com/software/haskell-options/")
+    (synopsis "Powerful and easy-to-use command-line option parser")
+    (description
+     "The @code{options} package lets library and application developers
+easily work with command-line options.")
+    (license license:expat)))
+
 ;;; haskell.scm ends here