summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-29 11:03:48 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-29 11:03:48 +0800
commita176dd7e248a5c18f26bc8fff0a3172eb44d9338 (patch)
tree47c0dcfe8249bd6512270c16494649edeb2c645d /gnu
parent310d218f64f2521a3285311ade7c30a3066450f4 (diff)
downloadguix-a176dd7e248a5c18f26bc8fff0a3172eb44d9338.tar.gz
gnu: Add libmodplug.
* gnu/packages/audio.scm (libmodplug): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 06f8bbdbea..5fc70c2561 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1136,6 +1136,28 @@ compression modes.  This package contains command-line programs and library to
 encode and decode wavpack files.")
     (license license:bsd-3)))
 
+(define-public libmodplug
+  (package
+    (name "libmodplug")
+    (version "0.8.8.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://sourceforge/project/modplug-xmms/"
+                    name "/" version "/" name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1bfsladg7h6vnii47dd66f5vh1ir7qv12mfb8n36qiwrxq92sikp"))))
+    (build-system gnu-build-system)
+    (home-page "http://modplug-xmms.sourceforge.net/")
+    (synopsis "Mod file playing library")
+    (description
+     "Libmodplug renders mod music files as raw audio data, for playing or
+conversion.  mod, .s3m, .it, .xm, and a number of lesser-known formats are
+supported.  Optional features include high-quality resampling, bass expansion,
+surround and reverb.")
+    (license license:public-domain)))
+
 (define-public soundtouch
   (package
     (name "soundtouch")